EtherChannelの設定



●Catalyst 2960でEtherChannelの設定

 参照
 EtherChannelおよびリンクステートトラッキングの設定

 使用する機器はCatalyst 2960の2台です。

 VLAN1を利用して設定

 RSTPが有効になっています。fa0/23-24をEtherChannelのグループとして2台とも設定します。

etherchannel01.png
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
!
  (途中省略)
!
interface FastEthernet0/1
 spanning-tree portfast
!
interface FastEthernet0/2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
 spanning-tree portfast
!
interface FastEthernet0/5
 spanning-tree portfast
!
interface FastEthernet0/6
 spanning-tree portfast
!
interface FastEthernet0/7
 spanning-tree portfast
!
interface FastEthernet0/8
 spanning-tree portfast
!         
interface FastEthernet0/9
 spanning-tree portfast
!
interface FastEthernet0/10
 spanning-tree portfast
!
interface FastEthernet0/11
 spanning-tree portfast
!
interface FastEthernet0/12
 spanning-tree portfast
!
  (途中省略)
!
interface FastEthernet0/23
 channel-group 1 mode on
!
interface FastEthernet0/24
 channel-group 1 mode on
!
 各スイッチのVLAN1に別々のIPアドレスを割り当て後、属しているポートにPCを接続してpingを打ちつづます。
 その間にfa0/23、fa0/24同士で接続されたLANケーブルを交互に抜いて確認したところ、そのまま通信され続けました

 VLAN1以外(VLAN20)を利用して設定

 fa0/13-16をVLAN20に属させます。そして、fa0/17-18をEtherChannelのグループ2として2台とも設定します。さっきと同様にRSTPが有効になっています。

etherchannel02.png
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
  (途中省略)
!
interface Port-channel2
 switchport access vlan 20
!
  (途中省略)
!         
interface FastEthernet0/13
 switchport access vlan 20
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport access vlan 20
 spanning-tree portfast
!
interface FastEthernet0/15
 switchport access vlan 20
 spanning-tree portfast
!         
interface FastEthernet0/16
 switchport access vlan 20
 spanning-tree portfast
!
interface FastEthernet0/17
 switchport access vlan 20
 channel-group 2 mode on
!
interface FastEthernet0/18
 switchport access vlan 20
 channel-group 2 mode on
!
 設定後、fa0/17-18にLANケーブルを接続したところRSTPによりブロックされてしまいました。
catalyst2960-2#show spanning-tree vlan 20
VLAN0020
  Spanning tree enabled protocol rstp
  Root ID    Priority    4096
             Address     0022.bd49.2000
             Cost        19
             Port        13 (FastEthernet0/13)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     001a.a266.9e80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/13              Root FWD 19        128.13   P2p 
Po2                 Altn BLK 12        128.72   P2p 
 これはVLAN1の時には起きなかった現象です。
 リモート接続用として接続されている各スイッチのfa0/13のいずれかを外すとブロックが解消されました。
 しかし、これではスイッチいずれかのfa0/13ポートからLANケーブルを外しておく必要があるので耐障害性を考慮すると現実的ではありません。

 VLAN1以外(VLAN20)を利用して設定(その2)

 「VLAN1以外(VLAN20)を利用して設定」の設定でVLAN20に属しているポートはfa0/13-18ですが、EtherChannelのグループとしてはfa0/17-18だけが設定されていました。
 この点を変更し、fa0/13-18をすべてEtherChannelのグループ2に属させます。
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
  (途中省略)
!
interface Port-channel2
 switchport access vlan 20
!
  (途中省略)
!
interface FastEthernet0/13
 switchport access vlan 20
 channel-group 2 mode on
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport access vlan 20
 channel-group 2 mode on
 spanning-tree portfast
!
interface FastEthernet0/15
 switchport access vlan 20
 channel-group 2 mode on
 spanning-tree portfast
!
interface FastEthernet0/16
 switchport access vlan 20
 channel-group 2 mode on
 spanning-tree portfast
!
interface FastEthernet0/17
 switchport access vlan 20
 channel-group 2 mode on
!
interface FastEthernet0/18
 switchport access vlan 20
 channel-group 2 mode on
!
 スパニングツリーの状態は下記のとおりです
catalyst2960-1#show spanning-tree vlan 20
VLAN0020
  Spanning tree enabled protocol rstp
  Root ID    Priority    4096
             Address     0022.bd49.2000
             Cost        9
             Port        72 (Port-channel2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     001a.a258.c900
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po2                 Root FWD 9         128.72   P2p 
catalyst2960-2#show spanning-tree vlan 20
VLAN0020
  Spanning tree enabled protocol rstp
  Root ID    Priority    4096
             Address     0022.bd49.2000
             Cost        9
             Port        72 (Port-channel2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     001a.a266.9e80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po2                 Root FWD 9         128.72   P2p
 スイッチのランプ等は想定とおりの問題なく点灯しています。
 ところが、リモートからスイッチ(VLAN20)に割り当てたIPアドレスに一方(catalyst2960-1)は応答があるものの、他方(catalyst2960-2)は応答がありませんでした。
catalyst3750-2#ping 172.17.1.252
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.1.252, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
catalyst3750-2#ping 172.17.1.251
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.1.251, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)